Petite galère avec MySQL
Hors ligneSteev94 Le 27/05/2006 à 01:10 Profil de Steev94 Configuration de Steev94

Bonjour a tous,

j'aimerais savoir quelque chose : en faite j'ai créer un serveur web (http, php, mysql) et je me rend compte que moi et mysql on est pas trè bon amis; en faite je trouve bizare que qd je me connecte a mysql il y ait comme nom d'utilisateur root@localhost

je voudrai savoir quel configueil faut changer car mon serveur mysql me servira surtout pour une zone membre, donc accessible d'internet et non de mon intranet local, si quelqu'un a une idée et/ou une petite explication claire concernant ma zone membre et la gestion de phpmyadmin sa me ferai plaisir

le port est bien redirigé mais lorsque je me connecte de ché qq'un d'autre par le net les page de phpmyadmin ne s'ouvre pas correctement alors que qd je le fais par localhost sa fonctionne! si quelqu'un peut m'expliquer vite fé le principe de la zone membre, des requette... sa serè cool,

merci d'avance et bon week end !
Hors ligneAnthony Le 27/05/2006 à 12:22 Profil de Anthony Configuration de Anthony

Fou du volant
Salut,

en fait ça signifie que tu te connectes en root à la base (tous les privilèges). Je te conseille de créer un utilisateur ayant des droits limités. Pour ce faire tu pourras consulter ce lien : Utilisateurs et droits - privilèges - MySQL.

Ensuite pour tes erreurs de connexion à distance, il faudrait être plus explicite.
--

Hors ligneSteev94 Le 27/05/2006 à 13:25 Profil de Steev94 Configuration de Steev94

re!

en faite j'ai déja créer un compte avec aucun privilège (le compte pma), mais si j'ai bien compri, les gens qui voudront s'inscrir sur mon site, avec les fichier conf.php, inscription.php, connexion.php sa établira une connexion sur mysql ver la base zone membre mais le problème quand j'essay de me connecter a phpmyadmin d'un post hors de mon réseau local, c a d en tapand l'adresse ip de ma connection ou ma redirection, par exemple www.steev-informatique.com/phpmyadmin/index.php sa s'affcihe, il y a la demande d'autentification, la page de gauche de phpmy admin s'affcihe avc la fentre SQL...mais a droite rien ne s'affiche ou sinon il y a que "créer une nouvelle base de donner" alors que quand je fé http://localhost/phpmyadmin/ il y a un menu beaucoup plus important et je me demande si cela ne va pas générer des erreur lorsque quelqu'un voudra s'incrire sur mon site!
Hors ligneAnthony Le 27/05/2006 à 13:41 Profil de Anthony Configuration de Anthony

Fou du volant
Non c'est justement à cause de ces privilèges que moins de choses s'affichent, et c'est tant mieux d'ailleurs.
--

Hors ligneDolfinger Le 27/05/2006 à 14:34 Profil de Dolfinger Configuration de Dolfinger

Généralement on fait un user par site web, sans droits d'admin juste les droits sur les db concernées.
Tout ca tu peux le gerer via phpmyadmin en te connectant en tant que root justement
Hors ligneSteev94 Le 28/05/2006 à 02:47 Profil de Steev94 Configuration de Steev94

oui sa je sais, j'ai créer un user avec aucun privilège, mais le problème est que j'ai acces a phpmyadmin quand passant par localhost mais par internet sa ne fonction pas très bien, donc je me pause la question si il n'y aura pas de probleme lorsque quelqu'un voudra s'inscrire sur le site sachant qu'une connexion a MySQL devra etre établi par internet et non par intranet local !
Hors ligneDolfinger Le 28/05/2006 à 09:21 Profil de Dolfinger Configuration de Dolfinger

Ca c'est un autre problème, a mon avis tu n'a pas acces à phpmyadmin par le net simplement à cause de ces lignes dans le httpd.conf de apache :



    
Alias /mysql/ "${path}/phpmyadmin/"

    <Directory "${path}/phpmyadmin">
        Options FollowSymLinks Indexes
        AllowOverride None
        Order deny,allow
        allow from 127.0.0.1
        deny from all
    </Directory>




Tu peux rajouter un allow from xxx.xxx.xxx.xxx ou il s'agit de ton adresse ip internet :)
Ca devrait fonctionner normalement, mais sinon pour vérifier que mysql est bien pris en charge par le net rien de plus simple tu fais une ptite page php avec une requete


+++

Dolf
Hors ligneAnthony Le 28/05/2006 à 10:39 Profil de Anthony Configuration de Anthony

Fou du volant
Allow from all pour permettre à tout le monde d'y accéder ;)
--

Hors ligneSteev94 Le 28/05/2006 à 19:29 Profil de Steev94 Configuration de Steev94

merci beaucoup, j'ai remplacer  "${path}/phpmyadmin/" par le chemin de phpmyadmin, mais par www.monsite.com/phpmyadmin sa ne s'affiche toujour pas comme qd je fé localhost/phpmyadmin/ peut etre que c'est normal non?

pourtant j'ai bien mi allow from all !

si vous voulé jpe vous mettre des screen sur mon site pour que vous voyez! Est ce que cela peu venir de conf.inc.php de phpmyadmin car l'adresse host de se dernier c'est localhost !

aller sur www.steev-informatique.com et je vous mettrez un scr de phpmyadmin qd je passe par localhost et un qd je passe par www.'/'

merci beaucoup !
Hors ligneAnthony Le 28/05/2006 à 20:18 Profil de Anthony Configuration de Anthony

Fou du volant
Merci d'écrire correctement STP...
--

Vous avez résolu votre problème avec VIC ? Faites-le savoir sur les réseaux sociaux !
Vulgarisation-informatique.com
Cours en informatique & tutoriels