validation W3C
Hors ligneJdalton42 Le 03/07/2007 à 00:12 Profil de Jdalton42 Configuration de Jdalton42

Bonsoir,

j'essaie de valider mon site (www.aidepc-fr.com) au W3C.

seulement, j'ai un probleme avec l'animation flash du dessus... j'ai trouvé sur le site de validation le bout de code valide à mettre pour afficher le flash mais toujours des erreurs, voici la page de validation pour voir les erreurs: ici

voici le bout de code qui affiche l'animation:

<object
classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
codebase="http://download.macromedia.com
/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0"
width="246" height="190" id="movie" align="">

<param name="movie" value="flash1.swf"/>
<embed src="flash1.swf" quality="high" width="246" height="190" name="movie" align=""
type="application/x-shockwave-flash"
plug inspage="http://www.macromedia.com/go/getflashplayer"/>

</object>
--
jdalton42
Hors ligneAnthony Le 03/07/2007 à 13:00 Profil de Anthony Configuration de Anthony

Fou du volant
Déjà quand il te dit "there is no attribute machin" ça veut dire qu'il faut que tu supprimes l'attribut machin. Donc en gros ton <table align="truc"> ça devient <table>

Ensuite pour le flash la balise embed doit en effet être remplacée par la balise object. Dans cette balise object, tu mets des balises <param name="src" value="blabla" />

par exemple ;) (ça remplace le <embed src="...."> qui n'est pas valide).

Tiens-nous au courant ;)

a +
--

Hors ligneJdalton42 Le 03/07/2007 à 21:25 Profil de Jdalton42 Configuration de Jdalton42

Salut,

bah le résultat si j'enleve le embed pour le remplacer par un param name="src", sa passe sous IE et pas sous firefox

de plus j'ai du ajouté se bout de code pour que se soit valide, et sous firefox, sa met des enormes ecars entre chaque image:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr" >
--
jdalton42
Hors ligneAnthony Le 03/07/2007 à 21:49 Profil de Anthony Configuration de Anthony

Fou du volant
Jdalton42 a écrit :
[...]et sous firefox, sa met des enormes ecars entre chaque image


ça n'a rien à voir, il faut adapter tes CSS. Pour l'attribut src il doit fonctionner sous IE et firefox, sinon ça peut être un attribut "filename" ou encore "data" tout dépend de l'objet en question.
--

Hors ligneJdalton42 Le 03/07/2007 à 22:30 Profil de Jdalton42 Configuration de Jdalton42

ok ok ^^ je vais voir ;) merci de ton aide
--
jdalton42
Vous avez résolu votre problème avec VIC ? Faites-le savoir sur les réseaux sociaux !
Vulgarisation-informatique.com
Cours en informatique & tutoriels