Problème serveur FTP
Hors ligneKéké Le 13/10/2008 ŕ 16:27 Profil de Kéké Configuration de Kéké

Bonsoir a tous et toutes!! tout le monde va bien???? :)  j'expose mon prob en esperant que quelqu'un puisse m'aider! J'ai un pc portable ou je suis connecté en wifi sur la livebox, y'a quelque jours j'ai installé un serveur ftp (zFTPServer), lorsque je me connecte a partir d'un client ftp sur mon reseaux local tout fonctionne bien! j'ai egalement fait un autre test a partir de ce site http://www.g6ftpserver.com/fr/ftptest  et sur mon serveur tout fonctionne correctement , par contre quand mon ami (client filezilla) essaye de s'y connecté  ca marche pas et ca lui marque ceci:

Statut :     Connexion à 90.5.32.188:65534 en cours...

Commande :     USER Camille
Réponse :     331 User name received, need password.
Commande :     PASS ****
Réponse :     230 User logged in, proceed.
Commande :     CLNT FileZilla
Réponse :     200 Noted.
Commande :     OPTS UTF8 ON
Réponse :     200 UTF8 ON
Statut :     Connecté
Statut :     Récupération du contenu du répertoire...
Commande :     PWD
Réponse :     257 "/" is working directory.
Commande :     TYPE I
Réponse :     200 Type set to I.
Commande :     PASV
Réponse :     227 Entering Passive Mode (192,168,1,10,8,0).
Statut :     Le serveur a retourné une adresse non routable, remplacée par l'adresse du serveur.
Commande :     LIST
Réponse :     150 Opening connection for /bin/ls.


Nous sommes tout les deux en wifi! Moi j'ai ouvert le port sur la livebox lui non serait ce ca le prob??  En esperant une reponse !! Merci d'avance a ce qui ce pencheront sur mon cas!!   bizz bizz

   Amicalement
   Kevin
Hors ligneTatave17 Le 13/10/2008 ŕ 17:41 Profil de Tatave17 Configuration de Tatave17

Papi Bidouille
bonjour
s'il possède une live boxe
je pense que la solution c'est d'allez dans la live box
serveur Lan
  ouvrir  un port
     mettre son IP local de son ordi en Wifi
       activez l'accès
Cordialement

PS attention au par feu ! donner des droits aussi
--
[couleur=#00CC66]N' oubliez pas de presser sur le bouton " Réponse accepté "à côté de la solution apportée si elle te convient[/couleur] [couleur=#0066FF]On aide plus un être en lui donnant de lui-même une image favorable qu'en le mettant sans cesse en face de ses défauts. "Albert Camus"[/couleur]
Hors ligneSpip5 Le 13/10/2008 ŕ 18:42 Profil de Spip5 Configuration de Spip5

Ecureuil fou
Il me semble qu'il faut non seulement qu'il ouvre aussi le port, mais aussi si vous avez plusieurs PC sur votre réseau local que vous fassiez une redirection de port vers le PC concerné pour les requêtes ftp.
--

Hors ligneKéké Le 14/10/2008 ŕ 10:49 Profil de Kéké Configuration de Kéké

Bonjour bonjour!!! Merci de vos réponses c'est gentil! Moi j'ai ouvert le port dans la live box et j'ai fait une exception dans le pare feu windows lui juste dans le pare feu!D'ailleurs en parlant de pare feu(windows) quand je clique dessus pour voir les détails il me dit que je suis protégé par COMODO firewell pro alors que je l'ai désinstaller y'a pas mal de temps! j'ai actuellement Sunbelt firewall ! je l'ai désactivé pour les tests du serveur mais windows me dit que j'ai deux pare feu d'activer mais je ne vois pas ou! j'ai regardé dans les processus et service j'ai rien du tout! je suis perdu:(   Est ce que cela peut poser problème pour ce connecter au serveur? Sinon je vous donne un acces et vous tentez de vous y connecter??

Spip5: oui j'ai un pc en wifi(moi) et le pc de mon père branché sur la live! Dois je ouvrir le port aussi sur sa machine? En vous remerciant.Bonne apres midi!
Hors ligneSpip5 Le 14/10/2008 ŕ 11:22 Profil de Spip5 Configuration de Spip5

Ecureuil fou
Soyons méthodique:
- Tu dois ouvrir les ports dans les pare-feu windows des postes émetteurs et récepteurs.
- Tu dois dans ton routeur (ta box) rediriger les requetes concernant le port utilisé par le protocole FTP vers ton pc en wifi, sinon la box ne saura pas vers quel ordinateur de ton réseau renvoyer les requêtes le concernant.
- Dans "ajout-suppression de programmes", Comodo a-t-il bien disparu depuis que tu dit l'avoir désinstallé ? Quand tu fait un CTRL+ALT+SUPP - onglet "processus", comodo n'apparaitrait-il pas ?
--

Hors ligneKéké Le 14/10/2008 ŕ 12:12 Profil de Kéké Configuration de Kéké

Coucou!! Concernant COMODO je n'ai aucun processus et il ne ce trouve pas dans "ajouts et suppressions de programmes"!  J'ai desinstallé Sunbelt firewall et windows me dit qu au moins un des pare feu est activé sur cet ordinateur et que ca peut provoquer des conflits! Pour ce qui est du serveur j'ai ouvert le port sur mon pc(wifi) , sur la live box et sur le pc de mon pere! J'ai fait des tests sur mon reseau et tout fonctionne a merveille! Mais pour mon ami ca lui a dit qu'il n'arrivait pas a lister les répertoires! Aurais tu une idee???  tu ne veux pas essayer de t'y connecter?
Hors ligneSpip5 Le 14/10/2008 ŕ 12:41 Profil de Spip5 Configuration de Spip5

Ecureuil fou
Kéké a écrit :
tu ne veux pas essayer de t'y connecter?
Non désolé, cela n'est pas dans ma politique d'aide: si je t'aide ainsi cela ne servira à personne d'autre qui tomberait sur ce fil par la suite.

Ton amis a-t-il aussi ouvert les port correspondant dans ses pare-feu et routeur ?

Tu dis qu'il n'arrive pas à lister les répertoires, mais arrive t-il au moins à se connecter à ton serveur ?
--

Hors ligneKéké Le 14/10/2008 ŕ 13:38 Profil de Kéké Configuration de Kéké

Re! Ha desolé mais c'etait juste pour que tu vois de toi meme ce que marque le client ftp! je ne suis pas un pro de l'informatique c'est pour ca! heuu il l'a bien ouvert dans son pare feu windows mais pas dans le routeur? est ce ca qui y fait?? Oui je le vois bien connecté sur le serveur mais il ne voit aucun repertoire ni dossier ni rien du tout! quand il ce connecte, sur mon serveur je vois "LIST"  ca ne devrait pas  etre "PWD" si ca fonctionné correctement??
Hors ligneSpip5 Le 16/10/2008 ŕ 18:50 Profil de Spip5 Configuration de Spip5

Ecureuil fou
Kéké a écrit :
Re! Ha desolé mais c'etait juste pour que tu vois de toi meme ce que marque le client ftp! je ne suis pas un pro de l'informatique c'est pour ca! heuu il l'a bien ouvert dans son pare feu windows mais pas dans le routeur? est ce ca qui y fait?? Oui je le vois bien connecté sur le serveur mais il ne voit aucun repertoire ni dossier ni rien du tout! quand il ce connecte, sur mon serveur je vois "LIST"  ca ne devrait pas  etre "PWD" si ca fonctionné correctement??

En cas de doute il vaut mieux qu'il redirige les requetes sur son routeur lui aussi puisqu'il semble ne pas l'avoir fait.
Mais apparemment il semble quand même réussi à se connecter. Si tu lui a créé un compte spécifique, lui as-tu bien donné les droits d'accès au répertoire d'accueil de ton serveur pour qu'il puisse en lister le contenu (droits de lecture) ? Je pense que c'est la question des droits qu'il faut creuser.
Je ne comprends pas ce que tu veux dire avec les commandes "list" et "pwd". "list" ne me dit rien et "pwd" sert à se situer au sein d'une arborescence, donc rien à voir avec le moyen de lister un répertoire. Sur un ftp en invite de commande les commandes sont les suivantes: http://www.commentcamarche.net/outils-reseau/commandes-ftp.php3
Donc il devrait taper "ls" (comme sous linux) pour voir le contenu du répertoire.
Si son répertoire d'accueil n'est pas le bon, c'est que son compte a été mal paramétré.
--

Hors ligneKéké Le 16/10/2008 ŕ 19:21 Profil de Kéké Configuration de Kéké

Bonsoir Spip5! Desolé de repondre que maintenant!oui je vais lui demandé qu'il redirige les requêtes sur son routeur! Comme droit d'acces je lui ai mit ceci:  FICHIERS => lire et ecrire       REPERTOIRE => lister
C'est bon non? avec ca il devrait pouvoir y avoir accès? Je te tiens au courant dès que j'aurai refait un test avec mon ami! Merci de ta patience   Bonne soiree ;)

Amicalement
kevin
Vous avez résolu votre problème avec VIC ? Faites-le savoir sur les réseaux sociaux !
Vulgarisation-informatique.com
Cours en informatique & tutoriels