problème d'accents avec MySQL
Hors ligneLucka Le 20/12/2007 à 03:58 Profil de Lucka Configuration de Lucka

Bonjour,

Je suis en train de créer un forum et j'utilise une table de données MySQL pour les noms de catégories et forums mais lorsque que je récupère les données pour afficher la page d'accueil, les accents ne s'affiche pas correctement, je soupçonne un problème de table de caractères mais je n'en trouve aucune me permettant d'avoir un affichage correct.

Au cas où ça vous serez utile voici la requète envoyée à la BDD ainsi que le code PHP affichant le texte incriminé.

mysql_select_db($BDDMySQL) OR die('Sélection de la base impossible');
$requete=mysql_query('SELECT `Type` , `Nom` , `nbre de messages` , `ID dernier message` FROM `Arborescence` ') OR die('Erreur de la requête MySQL');
mysql_close();

while($resultat=mysql_fetch_assoc($requete))

{

   if ($resultat['Type']=='Categorie')
   {
       echo"<tr>
                     <td colspan=2 class=CatégorieGauche>".$resultat['Nom']."</td>
                     <td colspan=2 class=CatégorieDroit></td>
               </tr>";
   }
   else
   {
      echo "<tr>
                     <td class=Forum1><img src=images/pas_de_nouveau.png border=0 alt='Pas De Nouveau' /></td>
                     <td class=Forum2><a href=/".$resultat['Nom'].".php class=forum>".$resultat['Nom']."</a></td>
                     <td class=Forum3>".$resultat['nbre de messages']."</td>
                     <td class=Forum4></td>
               </tr>";
   }
}
Hors ligneAnthony Le 20/12/2007 à 10:46 Profil de Anthony Configuration de Anthony

Fou du volant
Salut

Tes accents s'affichent comment ? je pense à un problème d'encodage, soit sur le site soit dans la base, en fait ton problème vient surement que tu n'utilises pas le même encodage.

Ton site est fait en ISO ou UTF-8 ?
--

Hors ligneLucka Le 20/12/2007 à 14:13 Profil de Lucka Configuration de Lucka

En fait à l'heure actuelle, j'ai deux mots qui posent problèmes: forêt et chaussée.

Le serveur est en utf-8 et mes fichiers en iso-8859-1, j'ai mis ma base de donnée en cp1252 mais MySQL reste en utf-8 et je n'ai rien trouvé pour le changer ni mon logiciel de traitement de texte.
Hors ligneAnthony Le 21/12/2007 à 18:08 Profil de Anthony Configuration de Anthony

Fou du volant
Avec un utf8_decode($donnee de la base); ça fonctionne ?

http://fr.php.net/manual/fr/function.utf8-decode.php
--

Vous avez résolu votre problème avec VIC ? Faites-le savoir sur les réseaux sociaux !
Vulgarisation-informatique.com
Cours en informatique & tutoriels