Wamp : Impossible d'acceder au Localhost
Hors ligneYusha Le 22/01/2008 à 22:12 Profil de Yusha Configuration de Yusha

Bonjour, bonsoir.

Je me suis inscrit sur ce forum car j'ai des soucis assez étrange sur Wamp. Lorsque je l'ai installé sur ma bécane, j'ai scrupuleusement suivis votre tutorial (très bien à ce propos).

Mon problème est simple, je n'arrive pas à accèder au Localhost / 127.0.0.1 , la page est en chargement pendant 10 minutes pour ensuite me dire qu'il n'y a rien. Bien évidement j'ai essayé de créer divers fichiers index.php

Au début, je me suis demandé si le port 80 n'était pas utilisé par une autre ressource, j'ai vérifié via un logiciel et il s'est avéré que non.



Cependant, ce même logiciel m'indique quelque chose d'étrange :

http://demon.fantasia.free.fr/divers/attente.jpg

Le service est en attente bizarrement. J'ai vérifié sur Apache l'option suivante :  Tester le port 80 , une page dos s'affiche et me met : Your Port 80 is Actually used by :     -      

Bon j'utilise McAfee comme firewall, j'ai crée des filtres, et j'ai mis "Autoriser complètement"  pour
httpd.exe. Même chose pour le parefeu de Windows ... Je l'ai même enlever à un moment pour lors de quelques tests.

Voici ce que j'obitens sur McAfee =>

Notons que l'adresse est de 0.0.0.0 et non de 127 comme elle devrait l'être.

Sur apache, j'ai un log d'erreurs, il m'était impossible de tout copier car d'un le fichier plante et qu'il est incroyablement long. Mais ces lignes reviennent souvent :

15:16:58 Apache.exe:3280 LOCK C:\Program Files\EasyPHP 2.0b1\apache\logs\error.log SUCCESS Excl: Yes Offset: 0 Length: -1

[Sat Sep 01 14:42:27 2007] [error] (OS 10038)Une opération a été tentée sur autre chose qu'un socket. : Child 332: Encountered too many errors accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive.

Je crois que je deviens fou.
Hors ligneAnthony Le 22/01/2008 à 22:54 Profil de Anthony Configuration de Anthony

Fou du volant
Salut et bienvenue sur le forum

En fait je pense très sincèrement que ton problème vient soit d'un pare-feu, soit d'une appli qui utilise le port. J'ai remaqué personnellement que lorsque j'avais MSN d'ouvert, ça déconnait parfois (apparemment msn peut utiliser le port 80). Vérifie que tu n'as pas msn de lancé, relance la création du service apache via Wamp et regarde si tu as une amélioration ;)

Pour ce qui est du pare-feu, quitte carrément norton et regarde aussi si ça améliore la chose
--

Hors ligneYusha Le 23/01/2008 à 00:30 Profil de Yusha Configuration de Yusha

Bonsoir Anthony ,

Je viens de couper le pare feu de XP, McAfee et Msn. Hélas rien n'y fait, j'ai sur mon fichier "www" mis un fichier index.php très rapide.

J'ai toujours "Your Port 80 is not actually used" ...
Hors ligneWAR10CK Le 23/01/2008 à 12:12 Profil de WAR10CK Configuration de WAR10CK

Salut j'utilise Apache et c'est pas "ça peut provenir de ..." c'est ça provient de MSN ou bien d'un parfeu, j'avais exactement le même soucis que toi :)

Et il s'est avéré que c'était un produit microsoft, je ne me souviens plus lequel parcontre :/

J'espére que j'ai pû apporter mon aide...
Hors ligneAnthony Le 23/01/2008 à 12:21 Profil de Anthony Configuration de Anthony

Fou du volant
On va essayer de ruser autrement. Ouvre le fichier httpd.conf situé dans le répertoire de Wamp puis bin\apache\apache-2.2.6\conf (ou une autre version).

Recherche la ligne Listen 80 et remplace-la par Listen 81.



Sauvegarde le fichier, ferme puis réouvre Wamp et enfin réinstalle tous les services (apache et mysql). Essaie ensuite de les lancer. Est-ce que ça se lance ?

Un accès à http://127.0.0.1:81 fonctionne t-il ?
--

Vous avez résolu votre problème avec VIC ? Faites-le savoir sur les réseaux sociaux !
Vulgarisation-informatique.com
Cours en informatique & tutoriels