Problème: Envoie de formulaire PHP vers Mysql
Hors ligneChtimi59250 Le 16/04/2008 à 17:59 Profil de Chtimi59250 Configuration de Chtimi59250

Bonjour,
Je suis débutant en php et j'ai créer une petit page en html (lecteur.htm) qui sert de lecteur divx sur internet.
Cette page contient un formulaire dans lequel les gens mette le nom du FILM et son URL.

---------------------------Code source de lecteur.htm---------------------------
<html>
<head><title>Lecteur DIVX</title></head>
<center>
<br><br>
<h3><u>Entre l'URL du DIVX dans la fenètre en dessous<br>
<form action="lecteur_divx.php" method="post">
<input type="text" name="url" />
<br>
<h3><u>Entre le nom du film</h3></u><br>
<input type="text" name="nom" />
<input type="submit" value="Valider" />
</form>
</center>
</html>
------------------------------------------------------------------------------------------­---


Cette page fonctionne très bien fonctionne très bien, ce n'est pas la mon problème.
Une fois validé on arrive donc sur la page "lecteur_divx.php".


---------------------------Code source de lecteur_divx.php---------------------------
<html>
<head><title><?php echo $_POST['nom']; ?></title></head>
<br><br><br><center><body background="tv.jpg">
<object classid="clsid:67DABFBF-D0AB-41fa-9C46-CC0F21721616" width="620" height="390" codebase="http://go.divx.com/plugin/DivXBrowserPlugin.cab">

<param name="custommode" value="none" />

<param name="autoPlay" value="false" />
<param name="src" value="<?php echo $_POST['url']; ?>" />

<embed type="video/divx" src="<?php echo $_POST['url']; ?>" custommode="none" width="620" height="390" autoPlay="false" pluginspage="http://go.divx.com/plugin/download/">
</embed>
</object>


<?php
mysql_connect("XXXXXXX", "XXXXXXXX", "motdepass");
mysql_select_db("XXXXXXXX");

// On ajoute une entrée avec mysql_query
mysql_query("INSERT INTO url VALUES('', '$nom', '$url')");

mysql_close();
?>

</center>
</html>
------------------------------------------------------------------------------------------­---------

La première partie du code(tout ce qui n'est pas la requête sql) fonctionne très bien.
La variable url est bien transmise (la vidéo marche) ainsi que la variable nom (se voit dans le nom de la page)

Mais c'est au niveau de la requêtes myysql que ça coince, je vous explique:
pour pouvoir voir le contenue de la table j'ai créer le fichier "film.php"


---------------------------Code source de film.php---------------------------
<?php
mysql_connect("???", "???", "???"); // Connexion à MySQL
mysql_select_db("???");

$reponse = mysql_query("SELECT * FROM url"); // Requête SQL


// On fait une boucle pour lister tout ce que contient la table :

while ($donnees = mysql_fetch_array($reponse) )
{
?>

<p>
<strong>ID DU FILM</strong> : <?php echo $donnees['id']; ?><br />
Nom du Film : <?php echo $donnees['nom']; ?><br />
URL du Film : <?php echo $donnees['url']; ?><br />
</p>

<?php
}

mysql_close(); // Déconnexion de MySQL
?>
------------------------------------------------------------------------------------------­---

Normalement je devrait voir apparaitre:
ID du film: 1
Nom du film: le nom qu'a mis la personne
URL du Film: l'URL qu'a mis la personne

Mais voici ce que j'obtiens:
ID DU FILM : 1
Nom du Film :
URL du Film :

Il incrémente bien mon ID mais ne transfert pas les variables dedans.

Voici la configurations de ma table:
Nom de la table: url
1er Champ: id Type=mediummint extra=auto_increment Action=primaire
2ème Champ: nom Type=longtext
3ème Champ: url Type=longtext


Pouvez-vous m'aider?
Hors ligneRyuzaki Le 16/04/2008 à 21:33 Profil de Ryuzaki Configuration de Ryuzaki

salut

tu t'es pas trompé  dans le nom de la base parce que j'ai remarqué que ton login et nom de la base sont identiques???

mysql_connect("XXXXXX", "XXXXXX", "XXXXXX");
mysql_select_db("XXXXXXX");


normalement c'est: mysql_select_db("nom_de_base");
Hors ligneAnthony Le 16/04/2008 à 23:35 Profil de Anthony Configuration de Anthony

Fou du volant
Salut

En effet, et sinon il n'est pas conseillé de laisser ses logins/passe sur le forum :) Je peux éditer ton message mais je t'invite à retirer ce que tu souhaites en cliquant sur l'icône dédiée (si tu n'y arrives pas je m'en chargerais)
--

Hors ligneChtimi59250 Le 17/04/2008 à 11:17 Profil de Chtimi59250 Configuration de Chtimi59250

J'ai trouver mon erreur, elle ne se trouve pas au niveau de la base ni le post vers la base mais des variables.
En effet j'ai oublier d'ajouter:
<?php
$nom = $_POST['nom'];
?>
<?php
$url = $_POST['url'];
?>

Je met la source exact pour une personne qui en aurait besoin ^^

-----------------------------------------film.php--------------------------------------------

<html>
<head>
<title><?php echo $_POST['nom']; ?></title>
</head>

<br><br><br><center><body background="http://lecteurdivx.ifrance.com/tv.jpg">
<object classid="clsid:67DABFBF-D0AB-41fa-9C46-CC0F21721616" width="620" height="390" codebase="http://go.divx.com/plugin/DivXBrowserPlugin.cab">

<param name="custommode" value="none" />

  <param name="autoPlay" value="false" />
  <param name="src" value="<?php echo $_POST['url']; ?>" />

<embed type="video/divx" src="<?php echo $_POST['url']; ?>" custommode="none" width="620" height="390" autoPlay="false"  pluginspage="http://go.divx.com/plugin/download/">
</embed>
<body text="#CC0000">
<h2><center><u><?php echo $_POST['nom']; ?></center></u></h2>
</body>
</object>
<?php
$nom = $_POST['nom'];
?>
<?php
$url = $_POST['url'];
?>
<?php
mysql_connect("???", "???", "???");
mysql_select_db("???");

// On ajoute une entrée avec mysql_query
mysql_query("INSERT INTO url VALUES('', '$nom', '$url')");

mysql_close();
?>

</center>
</html>

----------------------------------------------------------------------------------------
Hors ligneAnthony Le 17/04/2008 à 11:27 Profil de Anthony Configuration de Anthony

Fou du volant
Attention aux failles de sécurité : Failles PHP, pense aussi à regarder comment on fait proprement pour récupérer des valeurs provenant de formulaires : Formulaires en PHP
--

Hors ligneChtimi59250 Le 17/04/2008 à 11:53 Profil de Chtimi59250 Configuration de Chtimi59250

ok jvais essayé de voir au niveau des sécurité merci
Hors ligneKefren Le 18/04/2008 à 10:45 Profil de Kefren Configuration de Kefren

Je pasait dessus et j'ai remarqué qu'il restait les paramètre de connexion dans une reponse de Ryuzaki, alors je le souligne pour Anthony. Réédite avant que certaines personnes ne l'utilise ...
--
Si les poules traversent juste devant les voitures ... c'est pour aller de l'autre coté de la route !!!
Hors ligneAnthony Le 18/04/2008 à 14:01 Profil de Anthony Configuration de Anthony

Fou du volant
C'est fait :)
--

Vous avez résolu votre problème avec VIC ? Faites-le savoir sur les réseaux sociaux !
Vulgarisation-informatique.com
Cours en informatique & tutoriels