Verrouillage numérique sur le pavé numérique (W2k)
Hors ligneChrcvl62 Le 01/11/2005 à 21:50 Profil de Chrcvl62 Configuration de Chrcvl62

Bonjour à tous.

Nouveau venu sur ce forum, je lis avec plaisir des tas d'informations, d'explications, d'astuces que j'aurais aimé trouver en d'autres temps... Ce site me parait riche et bien fait.

Pour commencer, je voudrai poser une simple question qui est consécutive à une réinstallation complète de W2000. Mais, par rapport aux problèmes de certains, c'est vraiment un détail, tout juste agaçant.

Problème : le pavé numérique ne reste pas verrouillé sur numérique (NumLock = on).
Pourtant le verrouillage est activé dans le setup, mais, sous W2000, à l'invite de session et donc tout particulièrement à chaque changement d'utilisateur, le verrouillage est inactivé. Aussi les utilisateurs qui n'y prêtent pas attention se font piéger notamment lorsqu'ils utilisent des mots de passe comportant des chiffres.
Je sais poutant que cela est faisable puisqu'auparavant j'avais réglé le problème. Depuis, j'ai oublié...

Question : comment activer le verrouillage numérique du pavé numérique dès que l'invite de session apparaît ?
Est-ce une option cachée quelque part ou une ligne à modifier dans la base de registre ?

Merci.
Hors ligneAnthony Le 02/11/2005 à 21:42 Profil de Anthony Configuration de Anthony

Fou du volant
Salut,

il faut effectivement aller dans la base de registre de Windows. Clique sur démarrer, exécuter, tape regedit et clique sur Ok. Rends-toi ensuite à la clé suivante : HKEY_CURRENT_USER\Control Panel\Keyboard

modifie la chaîne suivante : InitialKeyboardIndicators et donne-lui la valeur 0 ou 2 en fonction de ce que tu souhaites (2 permettant de taper des chiffres).

a +
--

Hors ligneChrcvl62 Le 06/11/2005 à 23:15 Profil de Chrcvl62 Configuration de Chrcvl62

Bien joué... c'était presque bon du premier coup, mais c'est sûr la voie était la bonne.

Bonjour et merci d'avoir bien voulu me répondre.

1 - J'ai vérifié la valeur de HKEY_CURRENT_USER\Control Panel\Keyboard (InitialKeyboardIndicators) et elle était déjà sur la valeur 2. J'ai donc essayé la valeur 0, mais...sans résultat.

2 - Après de nombreux essais, je me suis rendu compte que, quelque soit la valeur de InitialKeyboardIndicator, le verrouillage numérique était toujours désactivé au moment de l'invite de session, puis après le demarrage de la session, il s'activait.

3 - En poursuivant, je me suis rendu compte qu'il existait une autre clé nommée HKEY_USERS\.DEFAULT\Control Panel\Keyboard (InitialKeyboardIndicators) dans la base de registre, attachée à User Defaut et non à Current user et, cette fois, c'était la bonne clé.

Merci, ça fonctionne comme je le souhaitais.

Christian.
Vous avez résolu votre problème avec VIC ? Faites-le savoir sur les réseaux sociaux !
Vulgarisation-informatique.com
Cours en informatique & tutoriels