fichier "System" manquant
Hors ligneTigene Le 09/11/2006 à 20:50 Profil de Tigene Configuration de Tigene

Viconaute Modérateur
chalut les tout le monde

PC sur lequel à l'allumage apparait le message :

Windows XP n'a pas pu démarrer, car le fichier suivant est manquant ou endommagé
WINDOWS\SYSTEM32\CONFIG\SYSTEM


démarrage sans échec pas possible, même message

démarrage avec le cd Wxp, puis Réparation, sans succès

procédure de Microsoft concernant ce message, pour remplacer ce fichier par celui du répertoire "Repair", sans succés.

je me suis rendu compte que ce fichier est manquant dans ce répertoire.

Puis-je aller le chercher sur le cd Wxp, pour le copier au bon endroit et comment ?

Merci pour la copine en rade.

Tigène perplexe
--

Ce n'est pas parce qu'on a quelque chose à dire, qu'il faut forcément l'ouvrir

Hors ligneMarculinos Le 09/11/2006 à 22:43 Profil de Marculinos Configuration de Marculinos

Viconaute Modérateur
Salut Tigene,

Le problème, c'est que tous les fichiers Windows sont compressés dans des fichiers .CAB
Il faut donc les éplucher un par un pour trouver le fichier. De plus, il n'est pas impossible qu'après avoir replacé le fichier en question Windows n'en réclame pas un autre.

Il est peut-être possible de réinstaller Windows par dessus l'installation existante sans formater. Tu démarres donc à partir du CD comme pour une installation, quand Windows te demandes si tu souhaites remplacer une installation existante ou effectuer une nouvelle installation, tu choisis la première solution. Tu passes ensuite par quasiment toute la phase d'installation classique. Pour finir, tu retrouves ton Windows avec tous ses programmes, ses icônes sur le bureau...
Je sais que je l'ai déjà fait sur un Windows 2000 pro. Cela avait parfaitement fonctionné. J'avais retrouvé le système comme avant le crash. Maintenant, je ne l'ai jamais pratiqué avec un Windows XP...

@+

Marc
Hors ligneAnthony Le 10/11/2006 à 00:03 Profil de Anthony Configuration de Anthony

Fou du volant
Salut les gars :)

Tigène > démarre avec le CD de XP et appuie sur "R" pour accéder à la console de récupération au lieu d'installer Windows. Ensuite une fois dans la console, lorsqu'elle te demande la session sur laquelle travailler, tu mets "1" puis tu appuies sur Entrée. Une fois que tu peux commander tout ça, il va falloir d'abord sauvegarder la base de registre actuelle :

copy c:\windows\system32\config\ c:\windows\tmp

Ensuite tu supprimes le registre existant (la commande rmdir c:\windows\system32\config doit fonctionner également, faudra simplement recréer le dossier c:\windows\system32\config après avec un mkdir) :

rmdir c:\windows\system32\config\ /S

Ensuite il faut restaurer le registre situé dans le répertoire repair de windows :

copy c:\windows\repair\ c:\windows\system32\config\

Tu redémarres une fois ceci fait ;)

a +
--

Hors ligneTigene Le 10/11/2006 à 00:38 Profil de Tigene Configuration de Tigene

Viconaute Modérateur
Merci les gars, mais j'ai déja fait ça :

Aide Microsoft a écrit :
md tmp
copy c:\windows\system32\config\system c:\windows\tmp\system.bak
copy c:\windows\system32\config\software c:\windows\tmp\software.bak
copy c:\windows\system32\config\sam c:\windows\tmp\sam.bak
copy c:\windows\system32\config\security c:\windows\tmp\security.bak
copy c:\windows\system32\config\default c:\windows\tmp\default.bak

delete c:\windows\system32\config\system
delete c:\windows\system32\config\software
delete c:\windows\system32\config\sam
delete c:\windows\system32\config\security
delete c:\windows\system32\config\default

copy c:\windows\repair\system c:\windows\system32\config\system
copy c:\windows\repair\software c:\windows\system32\config\software
copy c:\windows\repair\sam c:\windows\system32\config\sam
copy c:\windows\repair\security c:\windows\system32\config\security
copy c:\windows\repair\default c:\windows\system32\config\default


Mais en fait dans repair le fichier "system"  n'existe plus, et je ne sais pas ou aller le chercher

(PS : Anthony la commande "copy" ne marche pas pour les Directory et "xcopy" n'existe pas dans la console)
--

Ce n'est pas parce qu'on a quelque chose à dire, qu'il faut forcément l'ouvrir

Hors ligneAnthony Le 10/11/2006 à 14:41 Profil de Anthony Configuration de Anthony

Fou du volant
tigene a écrit :
(PS : Anthony la commande "copy" ne marche pas pour les Directory)


Ah ? normalement si, t'as un message d'erreur ?

Sinon le problème est que c'est justement dans le dossier repair qu'elle s'y trouve :(

Sinon je vois bien la solution de Marculinos qui consiste à faire une réinstallation par dessus, même si je trouve ça crade, au moins ça t'évite de perdre tes données.
--

Hors ligneTigene Le 10/11/2006 à 15:55 Profil de Tigene Configuration de Tigene

Viconaute Modérateur
je crois que je vais tenter la réinstal de Wxp, mais il me met un message comme quoi je risque de perdre des données et entre autre "mes documents"

je vais acheter un autre dd pour installer, car il y a des données précieuses pour la dame

@+
--

Ce n'est pas parce qu'on a quelque chose à dire, qu'il faut forcément l'ouvrir

Hors ligneTobby Le 10/11/2006 à 17:25 Profil de Tobby Configuration de Tobby

Or not tobby
salut tigene.
Le fichier System fait parti du noyau donc meme si tu le recupére du cd, c'est comme ci ton os etait vierge.

Aucune reparation ne pourras t'aider.
Le seul moyen qui existe est d'aller via un cd type ERd commander dans le repertoire et de modifié le fichier SYSTEM.SAV en SYSTEM
ca doit repartir.

Pour info le fichier existe mais il n'est pas consultable ni lisible via MS-DOS XP.

tu peut tenter via une disquette DOS avec  NTFS PRO.

Sinon installe un deuxième OS et tu pourras faire la manip.
--
80% des problèmes ce situe entre le clavier et la chaise
Hors ligneTigene Le 14/11/2006 à 19:37 Profil de Tigene Configuration de Tigene

Viconaute Modérateur
Merci Tobby

je me suis résolu a réinstaller Wxp, le PC fonctionne maintenant, mais le dossier "documents and settings/utilisateur" n'est pas accessible, accès refusé.

Or c'est la dedans qu'il y a les précieuses données.

quoi feur ?

______________________________________________________________________________________________
Edit du 15 11 2006 11h03 par Tigène

Voilà mon cher Tigène tu peux aller voir chez Microsoft ici

Oui, ça marche

Bravo Tigène, t'es vraiment un Ti-Génie

Merci Tigène

@+
--

Ce n'est pas parce qu'on a quelque chose à dire, qu'il faut forcément l'ouvrir

Hors ligneCarabinier Le 21/05/2008 à 06:52 Profil de Carabinier Configuration de Carabinier

Bonjour, j'ai besoin d'un peux d'aide

Windows a souvent du mal à démarrer

Dans le journal d'erreurs j'ai trouvé les messages suivant :

Application défaillante woobrowser.exe, version 5.9.2.0, module défaillant styleihm.dll, version 11.0.0.0, adresse de défaillance 0x0000b894.  

Application Error Application défaillante woobrowser.exe, version 5.9.2.0, module défaillant ieframe.dll, version 7.0.6000.16640, adresse de défaillance 0x0007be15

Merci A+
Hors ligneMarculinos Le 21/05/2008 à 22:34 Profil de Marculinos Configuration de Marculinos

Viconaute Modérateur
Bonjour !

Ceci est un message automatique. Le topic dans lequel vous avez répondu est trop vieux. Aussi, nous vous conseillons de créer votre topic pour avoir une réponse personnalisée

Les modérateurs
Vous avez résolu votre problème avec VIC ? Faites-le savoir sur les réseaux sociaux !
Vulgarisation-informatique.com
Cours en informatique & tutoriels