Envoi mail en html et texte
Hors ligneMarc59 Le 05/06/2006 à 19:29 Profil de Marc59 Configuration de Marc59

Bonjour,
Je souhaite envoyer des mails via php au format texte et également html. J'ai trouvé sur ce site un script le permettant mais il ne fonctionne pas. J'ai ajouté cette ligne sans sucès:

$destinataire='email_destinaire@fai.fr';


code du script:

<?php
//-----------------------------------------------
//DECLARE LES VARIABLES
//-----------------------------------------------
$email_expediteur='votre_mail@fai.fr';
$email_reply='email_de_reponse@fai.fr';
$message_texte='Bonjour,'."n\n".'Voici un message au format texte';

$message_html='<html>
<head>
<title>Titre</title>
</head>
<body>
<p>Test de message</p>
</body>
</html>'
;

//-----------------------------------------------
//GENERE LA FRONTIERE DU MAIL ENTRE TEXTE ET HTML
//-----------------------------------------------

$frontiere = '-----=' . md5(uniqid(mt_rand()));

//-----------------------------------------------
//HEADERS DU MAIL
//-----------------------------------------------

$headers = 'From: "Anthony Rossetto" <'.$email_expediteur.'>'."\n";
$headers .= 'Return-Path: <'.$email_reply.'>'."\n";
$headers .= 'MIME-Version: 1.0'."\n";
$headers .= 'Content-Type: multipart/alternative; boundary="'.$frontiere.'"';

//-----------------------------------------------
//MESSAGE TEXTE
//-----------------------------------------------
$message = 'This is a multi-part message in MIME format.'."\n\n";

$message .= '--'.$frontiere."\n";
$message .= 'Content-Type: text/plain; charset="iso-8859-1"'."\n";
$message .= 'Content-Transfer-Encoding: 8bit'."\n\n";
$message .= $message_texte."\n\n";

//-----------------------------------------------
//MESSAGE HTML
//-----------------------------------------------
$message .= '--'.$frontiere."\n";

$message .= 'Content-Type: text/html; charset="iso-8859-1"'."\n";
$message .= 'Content-Transfer-Encoding: 8bit'."\n\n";
$message .= $message_html."\n\n";

$message .= '--'.$frontiere.'--'."\n";

mail($destinataire,$sujet,$message,$headers);
?>


Auriez-vous une idée de ce qui cloche ?
Hors ligneAnthony Le 06/06/2006 à 00:02 Profil de Anthony Configuration de Anthony

Fou du volant
Salut,

il ne fonctionne pas c'est à dire ? quelle est l'erreur d'affichée ? aucune ?
--

Hors ligneMarc59 Le 06/06/2006 à 12:50 Profil de Marc59 Configuration de Marc59

Bonjour Anthony,

Non, je n'ai aucun message d'erreur, aucun email n'est reçu sur la boite de destination. La fonction mail est active chez mon hébergeur, je l'utilise actuellement pour envoyer des messages en html.

Une idée ?
Hors ligneAnthony Le 06/06/2006 à 22:09 Profil de Anthony Configuration de Anthony

Fou du volant
Quel est ton hébergeur et quel est le FAI du destinataire ? tu as essayé de t'envoyer un mail à toi-même avec le script ?
--

Hors ligneMarc59 Le 07/06/2006 à 18:37 Profil de Marc59 Configuration de Marc59

Bonjour ,

Mon hébergeur est keoconcept (l'offre gratuite) et le Fai du destinataire est NOSS. A partir de mon FAI (FREE) le message arrive chez :
free en fichier joint (même résultat avec du html seul)
yahoo, tiscali, ovh avec les caractères accentués
Noss, le message est passé un seule fois après plusieurs tentatives avec caractères non accentués

Quelque soit le destinataire les caractères " et ' posent problème et il n'y a pas de retour chariot. J'ai lu sur un forum qu'il suffisait d'ajouter  \n à la place d'un retour chariot mais ne saisissant pas moi même le contenu du message il m'est difficile de le rajouter !


Cordialement.
Vous avez résolu votre problème avec VIC ? Faites-le savoir sur les réseaux sociaux !
Vulgarisation-informatique.com
Cours en informatique & tutoriels